Верстка под старые браузеры

Беседы ни о чем

Верстка под старые браузеры

Сообщение archIvarIus3k » 23 апр 2022, 17:42

От нечего делать Захотелось соорудить себе что-то по типу типичного Web 1.0 - сайта, но при этом интересно сохранить 100% работоспособность со старьем, вроде IE 5.5-6, Firefox 2, и Opera 10.x (для беспроблемной работы в Win9x, без учета чего-то посвежее за счет KernelEx). Собственно - сойдет ли doctype - HTML 4.01 (или что старее взять), что и где почитать, про подводные камни совместимости этих старых версий?
Последний раз редактировалось archIvarIus3k 23 апр 2022, 17:43, всего редактировалось 1 раз.
archIvarIus3k
Опытный даунгрейдер
 
Сообщения: 18
Зарегистрирован: 03 апр 2022, 22:52

Re: Верстка под старые браузеры

Сообщение uav » 23 апр 2022, 17:56

В любом случае придётся проверять вручную на всех основных браузерах, т.к. не всегда документация содержит всю необходимую информацию.
На HTMLBook обычно совместимость по тэгам с браузерами указана:
http://htmlbook.ru/html/p
Можно на это ориентироваться.
Я вообще всякие мелкие сайты писал вручную на HTML в чём-то вроде Блокнота (в основном в AkelPad), при этом использовал как можно меньше тэгов (a, b, p, br, иногда table, даже div старался не использовать) - такие сайты обычно нормально открываются даже в самых старых браузерах.
Аватара пользователя
uav
Мастер Даунгрейда
 
Сообщения: 1116
Зарегистрирован: 22 дек 2008, 14:21

Re: Верстка под старые браузеры

Сообщение APTEMK » 24 апр 2022, 14:07

archIvarIus3k писал(а):Захотелось соорудить себе что-то по типу типичного Web 1.0 - сайта, но при этом интересно сохранить 100% работоспособность со старьем, вроде IE 5.5-6, Firefox 2, и Opera 10.x (для беспроблемной работы в Win9x, без учета чего-то посвежее за счет KernelEx). Собственно - сойдет ли doctype - HTML 4.01 (или что старее взять), что и где почитать, про подводные камни совместимости этих старых версий?


В принципе, сойдет, но нужен еще совместимый хостинг, поддерживающий стандарт HTTP.
http://betaoperating.mybb.ru/ - мой форум

Изображение
Аватара пользователя
APTEMK
Мастер Даунгрейда
 
Сообщения: 880
Зарегистрирован: 28 сен 2019, 10:54
Откуда: 10.12.2004 Приморский Край, Надеждинский р-н
Железо: 10.12.04компьютер Fujitsu (Pentium lll 550, 128 мб Озу, видеокарта ,Ati Rage Xl,Hdd 10 Гб, Windows98

Re: Верстка под старые браузеры

Сообщение uav » 24 апр 2022, 15:28

Да вроде большинство ещё HTTP поддерживает. Если это не хостинг с принудительным конструктором каким-нибудь.
Это вот если старые версии PHP, к примеру, нужны, чтобы старые движки использовать - это да, надо хостинг подбирать.
Последний раз редактировалось uav 24 апр 2022, 15:29, всего редактировалось 2 раз(а).
Аватара пользователя
uav
Мастер Даунгрейда
 
Сообщения: 1116
Зарегистрирован: 22 дек 2008, 14:21

Re: Верстка под старые браузеры

Сообщение KPG » 25 апр 2022, 17:15

А, из последних пока работоспособен FF52 под Win98 с kernelex?

Даже с каким то VPN плагином
Последний раз редактировалось KPG 25 апр 2022, 17:22, всего редактировалось 1 раз.
KPG
Мастер Даунгрейда
 
Сообщения: 231
Зарегистрирован: 21 окт 2015, 20:53

Re: Верстка под старые браузеры

Сообщение kvopper » 25 апр 2022, 18:18

KPG писал(а):А, из последних пока работоспособен FF52 под Win98 с kernelex?
Mypal Legacy также работоспособен.
У всех "не все дома", только в разной степени. "Все дома" только у бога.
96 DPI хватит всем!
kvopper
Матерый даунгрейдер
 
Сообщения: 98
Зарегистрирован: 14 май 2021, 11:50
Откуда: Латвия
Железо: Intel SE440BX2/P3-750/128MB/ATI Rage 128 Pro AGP 16MB/40GB/USB2 Hub Gembird/3com EtherLink 3


Вернуться в Флейм

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 3

cron