Об ограничении и прекращении поддержки старого ПО

Не DOS, но тоже нам интересно

Об ограничении и прекращении поддержки старого ПО

Сообщение N!k » 24 апр 2016, 10:41

25 апреля 2016 г. Яндекс прекращает поддержку устаревших версий почтовых программ.

Устаревшие версии почтовых программ

•Microsoft Outlook версий 2000, 2003;
•Microsoft Outlook версии 2007 на Windows XP (до SP3);
•Outlook Express на Windows XP (до SP3);
•The Bat! версии 4.0.37 и ниже;
•Apple Mail версии 3.1 и ниже (Mac OS X 10.5 и ниже);
•предустановленная почтовая программа на Android версий 1.6, 2.0;
•предустановленная почтовая программа на iOS версий 1, 2;
•предустановленная почтовая программа на Windows Mobile версии 6 и ниже.

Служба безопасности Яндекс.Почты выявила, что старые версии почтовых программ The Bat!, Mail.App и Microsoft Outlook не поддерживают новый безопасный протокол передачи данных. Устаревший протокол, по которому они работают, может стать причиной утечки информации и взломов почтовых ящиков.

Подробнее
Последний раз редактировалось N!k 24 апр 2016, 10:42, всего редактировалось 1 раз.
Изображение Изображение
Изображение
Аватара пользователя
N!k
Мастер Даунгрейда
 
Сообщения: 269
Зарегистрирован: 05 ноя 2014, 19:46
Откуда: Россия, Самарская обл.
Железо: Pentium III Celeron-1300, RAM 512 Mb, HDD 40 GB, fdd-3,5", Windows ME, Office XP

Re: Об ограничении и прекращении поддержки старого ПО

Сообщение Freeman » 24 апр 2016, 19:11

Я когда получил это письмо, сначала выругался матом, поскольку версии программ в самом письме не были указаны, а в моей версии The Bat! вроде бы всё в порядке с поддержкой протоколов шифрования. Потом оказалось, что я пользуюсь версией 4.2, а небезопасные -- 4.0. Отлегло.

Кстати, Opera 12.18 шустро работает со всеми современными сайтами, где нет слишком много JavaScript-а. Яндекс.Картами, например, теперь можно снова пользоваться, как в старое доброе время.
Разработчик языка программирования Кантор
Аватара пользователя
Freeman
Мастер Даунгрейда
 
Сообщения: 646
Зарегистрирован: 06 дек 2012, 05:49
Откуда: Санкт-Петербург

Re: Об ограничении и прекращении поддержки старого ПО

Сообщение zhasmin2004 » 01 май 2016, 22:19

А я все 9.22 оперой пользуюсь. Вот идиот..JavaScript всегда отключен. Правда сайты посещаю одни и теже. Old.dos vesti.ru kinogo YouTube, но тут уже JavaScript приходится включить и то видео не все подхватываются.
zhasmin2004
Матерый даунгрейдер
 
Сообщения: 78
Зарегистрирован: 31 авг 2014, 03:35
Откуда: Украина, Одесса

Re: Об ограничении и прекращении поддержки старого ПО

Сообщение Freeman » 02 май 2016, 10:19

У меня Bat ругается при отправке. Не предоставлен сертификат сервером, грит, такое соединение не может быть секретным. Жмешь "OK" -- он отправляет, но с такой цветомузыкой, боюсь, долго не протяну. Придется на новую версию переходить.
Разработчик языка программирования Кантор
Аватара пользователя
Freeman
Мастер Даунгрейда
 
Сообщения: 646
Зарегистрирован: 06 дек 2012, 05:49
Откуда: Санкт-Петербург

Re: Об ограничении и прекращении поддержки старого ПО

Сообщение Nika » 02 май 2016, 11:30

Freeman писал(а):У меня Bat ругается при отправке. Не предоставлен сертификат сервером, грит, такое соединение не может быть секретным. Жмешь "OK" -- он отправляет, но с такой цветомузыкой, боюсь, долго не протяну. Придется на новую версию переходить.
А версия какая?
У меня уже он давно работает только на приём. Версия 5.0.
"Administrative prohibitions - <<АдРеС ОтПрАвКи>> banned". Понял только, что то не с BAT'ом связано, более новую версию пробовал, то же самое.
Nika
Мастер Даунгрейда
 
Сообщения: 589
Зарегистрирован: 17 окт 2013, 00:21

Re: Об ограничении и прекращении поддержки старого ПО

Сообщение Freeman » 02 май 2016, 18:28

У меня версия 4.2.36.4.
Разработчик языка программирования Кантор
Аватара пользователя
Freeman
Мастер Даунгрейда
 
Сообщения: 646
Зарегистрирован: 06 дек 2012, 05:49
Откуда: Санкт-Петербург

Re: Об ограничении и прекращении поддержки старого ПО

Сообщение Nika » 02 май 2016, 22:49

Понятно..
Пробуйте версию 5.0.20.1 - c нею проблем быть не должно (за исключением написанного выше, но то не в BAt'e дело, а в моём провайдере хитромудром. Не у одного меня такая проблема, даже с новыми версиями Bat'а).
-> Install <-
Последний раз редактировалось Nika 02 май 2016, 23:00, всего редактировалось 1 раз.
Nika
Мастер Даунгрейда
 
Сообщения: 589
Зарегистрирован: 17 окт 2013, 00:21

Re: Об ограничении и прекращении поддержки старого ПО

Сообщение Freeman » 03 май 2016, 02:36

Nika писал(а):Пробуйте версию 5.0.20.1

С вашего позволения, версию выберу себе сам. :ugeek:

Кстати, никто не пробовал мою сборку утилиты LngUtil, вырезающую языки из lng-файла? Правил ее, чтобы работала с ресурсами новых версий. Выкладывал вроде на NoBat.ru, но там тогда был другой форум. Сейчас ссылки сыскать не могу. Если интересно, могу выложить здесь... Гм. С 7-й версией она не работает.
Разработчик языка программирования Кантор
Аватара пользователя
Freeman
Мастер Даунгрейда
 
Сообщения: 646
Зарегистрирован: 06 дек 2012, 05:49
Откуда: Санкт-Петербург

Re: Об ограничении и прекращении поддержки старого ПО

Сообщение Nika » 03 май 2016, 04:32

Freeman писал(а):
Nika писал(а):Пробуйте версию 5.0.20.1
С вашего позволения, версию выберу себе сам. :ugeek:
Ок, удалил.
Последний раз редактировалось Nika 03 май 2016, 04:32, всего редактировалось 1 раз.
Nika
Мастер Даунгрейда
 
Сообщения: 589
Зарегистрирован: 17 окт 2013, 00:21

Re: Об ограничении и прекращении поддержки старого ПО

Сообщение Freeman » 03 май 2016, 06:29

Пока суть да дело, научил утилиту работать с файлами 7-й версии Бата и нашел форум, на котором раньше выкладывал программу, туда же закинул ссылку новую версию.

На всякий продублирую тут: The Bat! LNG manipulation utility 1.04 (2016), скачать напрямую с Яндекс.Диска.
Разработчик языка программирования Кантор
Аватара пользователя
Freeman
Мастер Даунгрейда
 
Сообщения: 646
Зарегистрирован: 06 дек 2012, 05:49
Откуда: Санкт-Петербург

Re: Об ограничении и прекращении поддержки старого ПО

Сообщение zhasmin2004 » 03 май 2016, 21:02

Кстати выписали за сертификаты. Опера тоже ругается за сертификаты и мы долго не могли понять в чем дело. А оказалось дело в расхождении времени - моего компьютера и мирового времени.
zhasmin2004
Матерый даунгрейдер
 
Сообщения: 78
Зарегистрирован: 31 авг 2014, 03:35
Откуда: Украина, Одесса

Re: Об ограничении и прекращении поддержки старого ПО

Сообщение Freeman » 03 май 2016, 22:10

Ну вот, утилиту сделал, а теперь прочитал в интернетах, что в настройках S/MIME можно выбрать Microsoft Enhanced RSA and AES Cryptographic Provider в качестве поставщика шифрования, у него есть поддержка SHA-256. Выбрал, выставил. Работает! Теперь менять версию ни к чему. Windows XP.
Разработчик языка программирования Кантор
Аватара пользователя
Freeman
Мастер Даунгрейда
 
Сообщения: 646
Зарегистрирован: 06 дек 2012, 05:49
Откуда: Санкт-Петербург

Re: Об ограничении и прекращении поддержки старого ПО

Сообщение Freeman » 10 май 2016, 02:13

За это время выяснилось, что поставщик шифрования от Microsoft не работает с корпоративной почтой, так что переходить всё же придется.

В программе вырезания языков из Бата исправил все баги, и версию 1.05 выложил уже на ru-board. Получил одно спасибо и один удивленный вопрос, зачем экономить несколько мегабайт на диске. Как на него ответить не знаю. Все ответы грубыми кажутся. :oops:

Вы бы как на такой вопрос ответили?
Разработчик языка программирования Кантор
Аватара пользователя
Freeman
Мастер Даунгрейда
 
Сообщения: 646
Зарегистрирован: 06 дек 2012, 05:49
Откуда: Санкт-Петербург


Вернуться в Прочее

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 1